template matching takes so long and gets stuck

Discuss with developer team, share useful tips, report bugs, request new features and anything else
Post Reply
yun
Posts: 1
Joined: June 24th, 2016, 12:48 am

template matching takes so long and gets stuck

Post by yun » May 8th, 2019, 12:19 am

I have a template including about 100 blobs, the template matching takes hours and couldn't finish. It always gets stuck there. How can I fix it?

qtao
Posts: 142
Joined: October 7th, 2011, 10:16 am

Re: template matching takes so long and gets stuck

Post by qtao » May 8th, 2019, 8:53 am

It should not take that long if the matching settings are reasonable. I just tested matching with about 700 blobs. It took about a couple of seconds.

If some matching settings are set too big, matching could take much longer time. Also, if template peaks have qCLIC set, it will take more time to compute qCLIC such as match factors. But it still won't take that long to match.

Double check Configure > Settings > Template Matching
  • Set Search Space back to defaults;
  • Set Distance Threshold smaller.
If the RT variation is reasonable, Distance Thresholds can be set based on average peak widths. Usually Col I Threshold is around 3-5 (modulation periods), and Col II Threshold needs to be bigger (i.e. 5-20 sampling intervals) because RT2 has higher variation.

If the template is completely misaligned, you may want to use Template > Interactive Match and Transform to manually adjust the template first.

Post Reply